import Foundation
let pattern = #"(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4
Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)