import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*feat.*?)(\\s*\\(?feat.*\\)\\s*)(\\.[^\\.]+)$";
final String string = "Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4\n"
+ "Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4";
final String subst = "$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}