$re = '/(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$/m';
$str = 'Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4
Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;