const regex = /(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*feat.*?)(\\s*\\(?feat.*\\)\\s*)(\\.[^\\.]+)$', 'gm')
const str = `Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4
Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);