use strict;
my $str = 'Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4
Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4';
my $regex = qr/(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$/mp;
my $subst = '$1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";