package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$`)
var str = `Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4
Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4`
var substitution = "$1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}