re = /(.*feat.*?)(\s*\(?feat.*\)\s*)(\.[^\.]+)$/m
str = 'Artist - Song (feat. OtherArtist) (feat. OtherArtist).mp4
Artist - Song (feat. OtherArtist) (Radio Edit) (feat. OtherArtist).mp4'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result