# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)([a-zA-Z])|([a-zA-Z])(\d+)/$1$3-$2$4/gm;t' <<< "221B Baker Street
1107 Brooklyn Boulevard, Suite A350"