use strict;
my $str = '221B Baker Street
1107 Brooklyn Boulevard, Suite A350';
my $regex = qr/(\d+)([a-zA-Z])|([a-zA-Z])(\d+)/mp;
my $subst = '$1$3-$2$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";