const regex = /(\d+)([a-zA-Z])|([a-zA-Z])(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)([a-zA-Z])|([a-zA-Z])(\\d+)', 'gm')
const str = `221B Baker Street
1107 Brooklyn Boulevard, Suite A350`;
const subst = `$1$3-$2$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);