#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+)([a-zA-Z])|([a-zA-Z])(\d+)"
Local $sString = "221B Baker Street" & @CRLF & _
"1107 Brooklyn Boulevard, Suite A350"
Local $sSubst = "$1$3-$2$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)