using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)([a-zA-Z])|([a-zA-Z])(\d+)";
string substitution = @"$1$3-$2$4";
string input = @"221B Baker Street
1107 Brooklyn Boulevard, Suite A350";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}