package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)([a-zA-Z])|([a-zA-Z])(\d+)`)
var str = `221B Baker Street
1107 Brooklyn Boulevard, Suite A350`
var substitution = "$1$3-$2$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}