// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)([a-zA-Z])|([a-zA-Z])(\d+)").unwrap();
let string = "221B Baker Street
1107 Brooklyn Boulevard, Suite A350";
let substitution = "$1$3-$2$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}