import Foundation
let pattern = #"(\d+)([a-zA-Z])|([a-zA-Z])(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
221B Baker Street
1107 Brooklyn Boulevard, Suite A350
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3-$2$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)