import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)([a-zA-Z])|([a-zA-Z])(\\d+)";
final String string = "221B Baker Street\n"
+ "1107 Brooklyn Boulevard, Suite A350";
final String subst = "$1$3-$2$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}