$re = '/(\d+)([a-zA-Z])|([a-zA-Z])(\d+)/m';
$str = '221B Baker Street
1107 Brooklyn Boulevard, Suite A350';
$subst = "$1$3-$2$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;