#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$"
Local $sString = "random text!!!!" & @CRLF & _
"" & @CRLF & _
"YOUR_ANSWER" & @CRLF & _
"As_samp2 = 36" & @CRLF & _
"As_samp3 = 38 " & @CRLF & _
"#'END_ANSWER" & @CRLF & _
"" & @CRLF & _
"not your answer"
Local $sSubst = "space for answer"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)