const regex = /^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^YOUR_ANSWER\\s+.*?\\s+#\'END_ANSWER$', 'gms')
const str = `random text!!!!
YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#'END_ANSWER
not your answer`;
const subst = `space for answer`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);