using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$";
string substitution = @"space for answer";
string input = @"random text!!!!
YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#'END_ANSWER
not your answer";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}