re = /^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$/m
str = 'random text!!!!
YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#\'END_ANSWER
not your answer'
subst = 'space for answer'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result