$re = '/^YOUR_ANSWER\s+.*?\s+#\'END_ANSWER$/ms';
$str = 'random text!!!!
YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#\'END_ANSWER
not your answer';
$subst = "space for answer";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;