import Foundation
let pattern = ##"^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = ##"""
random text!!!!
YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#'END_ANSWER
not your answer
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"space for answer"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)