// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$").unwrap();
let string = "random text!!!!
YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#'END_ANSWER
not your answer";
let substitution = "space for answer";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}