use strict;
my $str = 'random text!!!!
YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#\'END_ANSWER
not your answer';
my $regex = qr/^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$/msp;
my $subst = 'space for answer';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";