# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$"
test_str = ("random text!!!!\n\n"
"YOUR_ANSWER\n"
"As_samp2 = 36\n"
"As_samp3 = 38 \n"
"#'END_ANSWER\n\n"
"not your answer")
subst = "space for answer"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.