package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^YOUR_ANSWER\s+.*?\s+#'END_ANSWER$`)
var str = `random text!!!!
YOUR_ANSWER
As_samp2 = 36
As_samp3 = 38
#'END_ANSWER
not your answer`
var substitution = "space for answer"
fmt.Println(re.ReplaceAllString(str, substitution))
}