import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)(:.*?)(?=\\s+\\w+:|$)";
final String string = "aaaaa: lorem ipsum bb: do lor sit amet ccc: no pro movet";
final String subst = "<b>$1</b>$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}