import Foundation
let pattern = #"(\w+)(:.*?)(?=\s+\w+:|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"aaaaa: lorem ipsum bb: do lor sit amet ccc: no pro movet"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$1</b>$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)