re = /(\w+)(:.*?)(?=\s+\w+:|$)/m
str = 'aaaaa: lorem ipsum bb: do lor sit amet ccc: no pro movet'
subst = '<b>$1</b>$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result