import re
regex = re.compile(r"(\w+)(:.*?)(?=\s+\w+:|$)", flags=re.MULTILINE)
test_str = "aaaaa: lorem ipsum bb: do lor sit amet ccc: no pro movet"
subst = "<b>$1</b>$2"
result = regex.sub(subst, test_str)
if result:
print(result)