#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)Описание книги(.*?)блок корзина"
Local $sString = "<!-- какой-то код -->" & @CRLF & _
"<h2>Описание книги</h2>" & @CRLF & _
"" & @CRLF & _
"<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>" & @CRLF & _
" <p>Цена: 1000 руб</p>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <div class="get">" & @CRLF & _
"" & @CRLF & _
"<!-- блок корзина-->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")