# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Описание книги(.*?)блок корзина"
test_str = ("<!-- какой-то код -->\n"
"<h2>Описание книги</h2>\n\n"
"<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>\n"
" <p>Цена: 1000 руб</p>\n\n\n"
" <div class=\"get\">\n\n"
"<!-- блок корзина-->")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.