import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Описание книги(.*?)блок корзина";
final String string = "<!-- какой-то код -->\n"
+ "<h2>Описание книги</h2>\n\n"
+ "<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>\n"
+ " <p>Цена: 1000 руб</p>\n\n\n"
+ " <div class=\"get\">\n\n"
+ "<!-- блок корзина-->";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}