using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Описание книги(.*?)блок корзина";
string input = @"<!-- какой-то код -->
<h2>Описание книги</h2>
<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>
<p>Цена: 1000 руб</p>
<div class=""get"">
<!-- блок корзина-->";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}