$re = '/Описание книги(.*?)блок корзина/ms';
$str = '<!-- какой-то код -->
<h2>Описание книги</h2>
<p>подробное описание подробное описание подробное оп исание подробное описание подробное описание </p>
<p>Цена: 1000 руб</p>
<div class="get">
<!-- блок корзина-->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);