const regex = /Описание книги(.*?)блок корзина/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Описание книги(.*?)блок корзина', 'gms')
const str = `<!-- какой-то код -->
<h2>Описание книги</h2>
<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>
<p>Цена: 1000 руб</p>
<div class="get">
<!-- блок корзина-->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}