use strict;
my $str = '<!-- какой-то код -->
<h2>Описание книги</h2>
<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>
<p>Цена: 1000 руб</p>
<div class="get">
<!-- блок корзина-->';
my $regex = qr/Описание книги(.*?)блок корзина/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}