re = /Описание книги(.*?)блок корзина/m
str = '<!-- какой-то код -->
<h2>Описание книги</h2>
<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>
<p>Цена: 1000 руб</p>
<div class="get">
<!-- блок корзина-->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end