package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)Описание книги(.*?)блок корзина`)
var str = `<!-- какой-то код -->
<h2>Описание книги</h2>
<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>
<p>Цена: 1000 руб</p>
<div class="get">
<!-- блок корзина-->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}