// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)Описание книги(.*?)блок корзина").unwrap();
let string = "<!-- какой-то код -->
<h2>Описание книги</h2>
<p>подробное описание подробное описание подробное описание подробное описание подробное описание </p>
<p>Цена: 1000 руб</p>
<div class=\"get\">
<!-- блок корзина-->";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}