using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<iframe.+?src="".*?)(?=:)";
string substitution = @"\1";
string input = @"<p>Some random text <iframe width=""425"" src=""http://some-random-link.com"" height=""350"" frameborder=""0""></iframe></p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}