import re
regex = re.compile(r"(<iframe.+?src=\".*?)(?=:)")
test_str = "<p>Some random text <iframe width=\"425\" src=\"http://some-random-link.com\" height=\"350\" frameborder=\"0\"></iframe></p>"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)