import Foundation
let pattern = #"(<iframe.+?src=".*?)(?=:)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p>Some random text <iframe width="425" src="http://some-random-link.com" height="350" frameborder="0"></iframe></p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)