const regex = /(<iframe.+?src=".*?)(?=:)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<iframe.+?src=".*?)(?=:)', 'g')
const str = `<p>Some random text <iframe width="425" src="http://some-random-link.com" height="350" frameborder="0"></iframe></p>`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);