import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<iframe.+?src=\".*?)(?=:)";
final String string = "<p>Some random text <iframe width=\"425\" src=\"http://some-random-link.com\" height=\"350\" frameborder=\"0\"></iframe></p>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}