re = /(<iframe.+?src=".*?)(?=:)/
str = '<p>Some random text <iframe width="425" src="http://some-random-link.com" height="350" frameborder="0"></iframe></p>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result