# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^']+?)[\]]/$1['$2']/gm;t' <<< "$row[number]; $row[user];
$row['number']; $row['user'];"