import Foundation
let pattern = #"(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^']+?)[\]]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$row[number]; $row[user];
$row['number']; $row['user'];
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1['$2']"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)