import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<variable>[$][a-zA-Z_\\x80-\\xff][a-zA-Z0-9_\\x80-\\xff]*)[[](?<index>[^']+?)[\\]]";
final String string = "$row[number]; $row[user];\n"
+ "$row['number']; $row['user'];";
final String subst = "$1['$2']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}